diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9f6de81..6702845 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -632,6 +632,9 @@ endif()
 option(USE_LIBIDN2 "Use libidn2 for IDN support" ON)
 set(HAVE_LIBIDN2 OFF)
 if(USE_LIBIDN2)
+  set(HAVE_LIBIDN2 TRUE)
+  list(INSERT CURL_LIBS 0 ${LIBIDN2_LINK_LIBRARIES})
+elseif(0)
   check_library_exists_concat("idn2" idn2_lookup_ul HAVE_LIBIDN2)
 endif()