yuzu/externals/vcpkg/ports/aws-c-event-stream/fix-cmake-target-path.patch

29 lines
972 B
Diff
Executable File

diff --git a/CMakeLists.txt b/CMakeLists.txt
index daf434c..32d7851 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,7 +91,7 @@ else()
endif()
install(EXPORT "${PROJECT_NAME}-targets"
- DESTINATION "${LIBRARY_DIRECTORY}/${PROJECT_NAME}/cmake/${TARGET_DIR}/"
+ DESTINATION "${LIBRARY_DIRECTORY}/${PROJECT_NAME}/cmake/"
NAMESPACE AWS::
COMPONENT Development)
diff --git a/cmake/aws-c-event-stream-config.cmake b/cmake/aws-c-event-stream-config.cmake
index 76adb84..7884368 100644
--- a/cmake/aws-c-event-stream-config.cmake
+++ b/cmake/aws-c-event-stream-config.cmake
@@ -2,9 +2,5 @@ include(CMakeFindDependencyMacro)
find_dependency(aws-c-io)
find_dependency(aws-checksums)
-if (BUILD_SHARED_LIBS)
- include(${CMAKE_CURRENT_LIST_DIR}/shared/@PROJECT_NAME@-targets.cmake)
-else()
- include(${CMAKE_CURRENT_LIST_DIR}/static/@PROJECT_NAME@-targets.cmake)
-endif()
+include(${CMAKE_CURRENT_LIST_DIR}/@CMAKE_PROJECT_NAME@-targets.cmake)