17 lines
619 B
Diff
Executable File
17 lines
619 B
Diff
Executable File
--- meson.build.orig 2022-03-19 03:40:07.000000000 +0900
|
|
+++ meson.build 2022-03-29 21:32:41.000000000 +0900
|
|
@@ -100,6 +100,13 @@
|
|
# Autotools compatibility
|
|
add_project_arguments('-DHAVE_CONFIG_H', language: 'c')
|
|
|
|
+if host_machine.system() == 'windows'
|
|
+ lib_default = get_option('default_library')
|
|
+ if lib_default == 'static'
|
|
+ add_project_arguments('-DCAIRO_WIN32_STATIC_BUILD', language: 'c')
|
|
+ endif
|
|
+endif
|
|
+
|
|
# Make sure source directory hasn't been configured with autotools
|
|
fs = import('fs')
|
|
if fs.exists('config.h') or fs.exists('src/cairo-features.h') or fs.exists('src/cairo-supported-features.h')
|