29 lines
835 B
Diff
Executable File
29 lines
835 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index b353be6..419e983 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -150,6 +150,10 @@ else()
|
|
endif()
|
|
endif()
|
|
|
|
+if(MSVC)
|
|
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4996")
|
|
+endif()
|
|
+
|
|
option(REGENERATE_AMQP_FRAMING "Regenerate amqp_framing.h/amqp_framing.c sources (for developer use)" OFF)
|
|
mark_as_advanced(REGENERATE_AMQP_FRAMING)
|
|
|
|
diff --git a/librabbitmq/CMakeLists.txt b/librabbitmq/CMakeLists.txt
|
|
index d8dcd26..671840b 100644
|
|
--- a/librabbitmq/CMakeLists.txt
|
|
+++ b/librabbitmq/CMakeLists.txt
|
|
@@ -108,7 +108,7 @@ set(RABBITMQ_SOURCES
|
|
${AMQP_SSL_SRCS}
|
|
)
|
|
|
|
-add_definitions(-DAMQP_BUILD)
|
|
+add_definitions(-DAMQP_BUILD -D_CRT_SECURE_NO_WARNINGS)
|
|
|
|
set(RMQ_LIBRARIES ${AMQP_SSL_LIBS} ${SOCKET_LIBRARIES} ${LIBRT} ${CMAKE_THREAD_LIBS_INIT})
|
|
|