17 lines
587 B
Diff
Executable File
17 lines
587 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 4f81148..8006536 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -158,3 +158,11 @@ install(
|
|
FILES ${config_version_file}
|
|
DESTINATION ${INSTALL_CMAKE_DIR} COMPONENT Development
|
|
)
|
|
+
|
|
+set(prefix ${CMAKE_INSTALL_PREFIX})
|
|
+set(exec_prefix ${CMAKE_INSTALL_PREFIX})
|
|
+set(includedir ${CMAKE_INSTALL_PREFIX}/include)
|
|
+set(libdir ${CMAKE_INSTALL_PREFIX}/lib)
|
|
+set(PACKAGE_VERSION 0.1)
|
|
+configure_file(yaml-0.1.pc.in ${PROJECT_BINARY_DIR}/yaml-0.1.pc @ONLY)
|
|
+install(FILES ${PROJECT_BINARY_DIR}/yaml-0.1.pc DESTINATION lib/pkgconfig)
|