22 lines
804 B
Diff
Executable File
22 lines
804 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt (date 1618364429263)
|
|
+++ b/CMakeLists.txt (date 1618364429263)
|
|
@@ -170,7 +170,7 @@
|
|
string(REGEX REPLACE ".*#define[ \t]+ZLIB_VERSION[ \t]+\"([-0-9A-Za-z.]+)\".*"
|
|
"\\1" ZLIB_FULL_VERSION ${_zlib_h_contents})
|
|
|
|
-if(MINGW)
|
|
+if(MINGW AND NOT ANDROID)
|
|
# This gets us DLL resource information when compiling on MinGW.
|
|
if(NOT CMAKE_RC_COMPILER)
|
|
set(CMAKE_RC_COMPILER windres.exe)
|
|
@@ -186,7 +186,7 @@
|
|
if(BUILD_SHARED_LIBS)
|
|
set(ZLIB_DLL_SRCS ${CMAKE_CURRENT_BINARY_DIR}/zlib1rc.obj)
|
|
endif()
|
|
-endif(MINGW)
|
|
+endif(MINGW AND NOT ANDROID)
|
|
|
|
add_library(zlib ${ZLIB_SRCS} ${ZLIB_ASMS} ${ZLIB_DLL_SRCS} ${ZLIB_PUBLIC_HDRS} ${ZLIB_PRIVATE_HDRS})
|
|
set_target_properties(zlib PROPERTIES DEFINE_SYMBOL ZLIB_DLL)
|