21 lines
435 B
Diff
Executable File
21 lines
435 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -51,8 +51,15 @@ set(SRC_FILES
|
|
src/CascRootFile_WoW.cpp
|
|
)
|
|
|
|
+if(WIN32)
|
|
+ set(SRC_FILES ${SRC_FILES}
|
|
+ src/DllMain.c
|
|
+ src/DllMain.def
|
|
+ )
|
|
+endif()
|
|
+
|
|
set(LINK_LIBS)
|
|
-find_package(ZLIB)
|
|
+find_package(ZLIB REQUIRED)
|
|
if (ZLIB_FOUND)
|
|
set(LINK_LIBS ${LINK_LIBS} ZLIB::ZLIB)
|
|
add_definitions(-DCASC_USE_SYSTEM_ZLIB)
|