16 lines
621 B
Diff
Executable File
16 lines
621 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 8b2e428..ea430f4 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1505,7 +1505,9 @@ set(includedir "\${prefix}/include")
|
|
set(LDFLAGS "${CMAKE_SHARED_LINKER_FLAGS}")
|
|
set(LIBCURL_LIBS "")
|
|
set(libdir "${CMAKE_INSTALL_PREFIX}/lib")
|
|
-foreach(_lib ${CMAKE_C_IMPLICIT_LINK_LIBRARIES} ${CURL_LIBS})
|
|
+set(CURL_LIBS_FLAT "")
|
|
+vcpkg_curl_flatten(CURL_LIBS CURL_LIBS_FLAT)
|
|
+foreach(_lib ${CURL_LIBS_FLAT})
|
|
if(TARGET "${_lib}")
|
|
set(_libname "${_lib}")
|
|
get_target_property(_imported "${_libname}" IMPORTED)
|