16 lines
779 B
Diff
Executable File
16 lines
779 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index e4ea71c..df37028 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -517,8 +517,9 @@ else(NOT enable-pkgconfig)
|
|
find_package ( PkgConfig REQUIRED )
|
|
|
|
# Mandatory libraries: glib and gthread
|
|
- pkg_check_modules ( GLIB REQUIRED glib-2.0>=2.6.5 gthread-2.0>=2.6.5 )
|
|
+ pkg_check_modules ( GLIB IMPORTED_TARGET REQUIRED glib-2.0>=2.6.5 gthread-2.0>=2.6.5 )
|
|
list( APPEND PC_REQUIRES_PRIV "glib-2.0" "gthread-2.0")
|
|
+ set(GLIB_LIBRARIES PkgConfig::GLIB)
|
|
|
|
if ( GLIB_glib-2.0_VERSION AND GLIB_glib-2.0_VERSION VERSION_LESS "2.26.0" )
|
|
message ( WARNING "Your version of glib is very old. This may cause problems with fluidsynth's sample cache on Windows. Consider updating to glib 2.26 or newer!" )
|