49 lines
1.9 KiB
Diff
Executable File
49 lines
1.9 KiB
Diff
Executable File
From 04bb359c724308e30268840c64932ea1d05b9077 Mon Sep 17 00:00:00 2001
|
|
From: Nicole Mazzuca <mazzucan@outlook.com>
|
|
Date: Wed, 23 Sep 2020 10:00:23 -0700
|
|
Subject: [PATCH 1/2] remove install prefix
|
|
|
|
---
|
|
CMakeLists.txt | 4 ----
|
|
1 file changed, 4 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index f7372bf..f3c11f1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -26,7 +26,6 @@ set(FMILIBRARYHOME ${FMILibrary_SOURCE_DIR})
|
|
set(FMILIBRARYBUILD ${FMILibrary_BINARY_DIR})
|
|
|
|
# User configuration options and parameters
|
|
-SET(FMILIB_INSTALL_PREFIX ${FMILibrary_BINARY_DIR}/../install CACHE PATH "Prefix prepended to install directories")
|
|
set(FMILIB_THIRDPARTYLIBS ${FMILibrary_SOURCE_DIR}/ThirdParty CACHE PATH "Path to the ThirdParty library dir" )
|
|
set(FMILIB_FMI_STANDARD_HEADERS ${FMILIB_THIRDPARTYLIBS}/FMI/default CACHE PATH "Path to the FMI standard headers dir" )
|
|
|
|
@@ -84,7 +83,6 @@ IF(NOT CMAKE_BUILD_TYPE)
|
|
SET(CMAKE_BUILD_TYPE ${FMILIB_DEFAULT_BUILD_TYPE})
|
|
ENDIF(NOT CMAKE_BUILD_TYPE)
|
|
|
|
-SET(CMAKE_INSTALL_PREFIX ${FMILIB_INSTALL_PREFIX} CACHE INTERNAL "Prefix prepended to install directories" FORCE)
|
|
|
|
# debug_message is used to trace the build script
|
|
function(debug_message)
|
|
@@ -350,7 +348,6 @@ endfunction()
|
|
|
|
if(FMILIB_GENERATE_DOXYGEN_DOC)
|
|
|
|
- file(MAKE_DIRECTORY "${FMILIB_INSTALL_PREFIX}/doc")
|
|
|
|
set(DOXYFILE_IN ${FMILIBRARYHOME}/Config.cmake/fmilib_doxydoc.conf CACHE INTERNAL "Doxygen config file")
|
|
set(DOXYFILE_IMAGE_DIR "${FMILIBRARYHOME}/images" CACHE INTERNAL "Doxygen images" FORCE)
|
|
@@ -372,7 +369,6 @@ if(FMILIB_GENERATE_DOXYGEN_DOC)
|
|
set(DOXYFILE_SOURCE_DIR "${FMILIBRARYBUILD}/doc" CACHE INTERNAL "Doxygen default source dir" FORCE)
|
|
set(DOXYFILE_EXTRA_SOURCES "${DOXYFILE_EXTRA_SOURCES} \"${FMILIBRARYHOME}/Test\"")
|
|
|
|
- set(DOXYFILE_OUTPUT_DIR "${FMILIB_INSTALL_PREFIX}/doc")
|
|
|
|
set(DOXYFILE_STRIP_FROM_PATH "${FMILIBRARYHOME}")
|
|
|
|
--
|
|
2.24.3 (Apple Git-128)
|
|
|