28 lines
1.1 KiB
Diff
Executable File
28 lines
1.1 KiB
Diff
Executable File
diff --git a/src/designer/src/components/lib/CMakeLists.txt b/src/designer/src/components/lib/CMakeLists.txt
|
|
index 53358741f..ce070bd6a 100644
|
|
--- a/src/designer/src/components/lib/CMakeLists.txt
|
|
+++ b/src/designer/src/components/lib/CMakeLists.txt
|
|
@@ -878,7 +878,7 @@ qt_internal_add_resource(DesignerComponents "widgetbox"
|
|
## Scopes:
|
|
#####################################################################
|
|
|
|
-qt_internal_extend_target(DesignerComponents CONDITION static
|
|
+qt_internal_extend_target(DesignerComponents CONDITION NOT BUILD_SHARED_LIBS
|
|
DEFINES
|
|
QT_DESIGNER_STATIC
|
|
)
|
|
diff --git a/src/designer/src/designer/CMakeLists.txt b/src/designer/src/designer/CMakeLists.txt
|
|
index f786f1dd6..8c635ff14 100644
|
|
--- a/src/designer/src/designer/CMakeLists.txt
|
|
+++ b/src/designer/src/designer/CMakeLists.txt
|
|
@@ -103,8 +103,8 @@ qt_internal_extend_target(designer CONDITION TARGET Qt::PrintSupport
|
|
PUBLIC_LIBRARIES
|
|
Qt::PrintSupport
|
|
)
|
|
|
|
-qt_internal_extend_target(designer CONDITION QT_CONFIG___contains___static
|
|
+qt_internal_extend_target(designer CONDITION NOT BUILD_SHARED_LIBS
|
|
DEFINES
|
|
QT_DESIGNER_STATIC
|
|
)
|