15 lines
385 B
Diff
Executable File
15 lines
385 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 33b8e2c..e8c1cc2 100755
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -148,6 +148,9 @@ if(HAVE_C-ARES)
|
|
set(private_headers
|
|
${private_headers}
|
|
trantor/net/inner/AresResolver.h)
|
|
+ if(APPLE)
|
|
+ target_link_libraries(${PROJECT_NAME} PRIVATE resolv)
|
|
+ endif()
|
|
else()
|
|
set(TRANTOR_SOURCES
|
|
${TRANTOR_SOURCES}
|