26 lines
1.1 KiB
Diff
Executable File
26 lines
1.1 KiB
Diff
Executable File
diff --git a/internal/ceres/CMakeLists.txt b/internal/ceres/CMakeLists.txt
|
|
index 0e33263..299b373 100644
|
|
--- a/internal/ceres/CMakeLists.txt
|
|
+++ b/internal/ceres/CMakeLists.txt
|
|
@@ -101,17 +101,9 @@ endif()
|
|
find_package(Threads QUIET)
|
|
list(APPEND CERES_LIBRARY_PUBLIC_DEPENDENCIES Threads::Threads)
|
|
|
|
-if (NOT MINIGLOG AND GLOG_FOUND)
|
|
- list(APPEND CERES_LIBRARY_PUBLIC_DEPENDENCIES ${GLOG_LIBRARIES})
|
|
- if (gflags_FOUND)
|
|
- # If glog & gflags are both found, we assume that glog was built with
|
|
- # gflags, as it is awkward to perform a try_compile() to verify this
|
|
- # when gflags is an imported target (as it is in newer versions).
|
|
- # As glog #includes gflags/gflags.h in glog/logging.h if compiled with
|
|
- # gflags, it is thus a public dependency for Ceres in this case.
|
|
- list(APPEND CERES_LIBRARY_PUBLIC_DEPENDENCIES gflags)
|
|
- endif()
|
|
-endif (NOT MINIGLOG AND GLOG_FOUND)
|
|
+if (NOT MINIGLOG)
|
|
+ list(APPEND CERES_LIBRARY_PUBLIC_DEPENDENCIES glog::glog)
|
|
+endif (NOT MINIGLOG)
|
|
|
|
if (SUITESPARSE AND SuiteSparse_FOUND)
|
|
# Define version information for use in Solver::FullReport.
|