16 lines
484 B
Diff
Executable File
16 lines
484 B
Diff
Executable File
diff --git a/clickhouse/CMakeLists.txt b/clickhouse/CMakeLists.txt
|
|
index 7e10ffd..cbbffdc 100644
|
|
--- a/clickhouse/CMakeLists.txt
|
|
+++ b/clickhouse/CMakeLists.txt
|
|
@@ -31,6 +31,10 @@ SET ( clickhouse-cpp-lib-src
|
|
query.cpp
|
|
)
|
|
|
|
+if (MSVC)
|
|
+ add_compile_options(/wd4996)
|
|
+endif()
|
|
+
|
|
ADD_LIBRARY (clickhouse-cpp-lib SHARED ${clickhouse-cpp-lib-src})
|
|
SET_TARGET_PROPERTIES(clickhouse-cpp-lib PROPERTIES LINKER_LANGUAGE CXX)
|
|
TARGET_LINK_LIBRARIES (clickhouse-cpp-lib
|