yuzu/externals/vcpkg/ports/freeglut/windows-static-output-name....

30 lines
1.0 KiB
Diff
Executable File

diff --git a/CMakeLists.txt b/CMakeLists.txt
index aec0a27..73ccbdb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -429,7 +429,7 @@ IF(WIN32)
ENDIF()
IF(FREEGLUT_BUILD_STATIC_LIBS)
TARGET_COMPILE_DEFINITIONS(freeglut_static PUBLIC FREEGLUT_STATIC)
- IF(FREEGLUT_REPLACE_GLUT)
+ IF(1)
SET_TARGET_PROPERTIES(freeglut_static PROPERTIES OUTPUT_NAME ${LIBNAME})
ENDIF()
ENDIF()
diff --git a/include/GL/freeglut_std.h b/include/GL/freeglut_std.h
index a5efb3b..6bdcdfb 100644
--- a/include/GL/freeglut_std.h
+++ b/include/GL/freeglut_std.h
@@ -71,9 +71,9 @@
/* Link with Win32 static freeglut lib */
# if FREEGLUT_LIB_PRAGMAS
# if defined(NDEBUG) || !defined(_DEBUG)
-# pragma comment (lib, "freeglut_static.lib")
+# pragma comment (lib, "freeglut.lib")
# else
-# pragma comment (lib, "freeglut_staticd.lib")
+# pragma comment (lib, "freeglutd.lib")
# endif
# endif