54 lines
1.7 KiB
Diff
Executable File
54 lines
1.7 KiB
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index ea9fd15..af63d1e 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -7,7 +7,7 @@
|
|
cmake_minimum_required(VERSION 3.0 FATAL_ERROR)
|
|
|
|
# Include cmake modules
|
|
-list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
|
|
+# list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
|
|
|
|
include(GenerateExportHeader)
|
|
|
|
diff --git a/source/cppfs/CMakeLists.txt b/source/cppfs/CMakeLists.txt
|
|
index aa37eda..d29176a 100644
|
|
--- a/source/cppfs/CMakeLists.txt
|
|
+++ b/source/cppfs/CMakeLists.txt
|
|
@@ -4,18 +4,18 @@
|
|
#
|
|
|
|
find_package(LibSSH2)
|
|
-find_package(LibCrypto)
|
|
+# find_package(LibCrypto)
|
|
find_package(ZLIB)
|
|
find_package(OpenSSL)
|
|
|
|
-if (LibSSH2_FOUND AND LibCrypto_FOUND AND ZLIB_FOUND AND OpenSSL_FOUND)
|
|
+if (LibSSH2_FOUND AND ZLIB_FOUND AND OpenSSL_FOUND)
|
|
set(SSH_DEPS_MET TRUE)
|
|
else()
|
|
set(SSH_DEPS_MET FALSE)
|
|
endif()
|
|
|
|
if (OPTION_BUILD_SSH_BACKEND AND NOT SSH_DEPS_MET)
|
|
- message(FATAL_ERROR "Requested to build ssh module but not all dependencies are found! LibSSH2: ${LibSSH2_FOUND}, LibCrypto: ${LibCrypto_FOUND}, ZLIB: ${ZLIB_FOUND}, OpenSSL: ${OpenSSL_FOUND}")
|
|
+ message(FATAL_ERROR "Requested to build ssh module but not all dependencies are found! LibSSH2: ${LibSSH2_FOUND}, ZLIB: ${ZLIB_FOUND}, OpenSSL: ${OpenSSL_FOUND}")
|
|
endif()
|
|
|
|
|
|
@@ -207,10 +207,9 @@ target_link_libraries(${target}
|
|
if (OPTION_BUILD_SSH_BACKEND)
|
|
target_link_libraries(${target}
|
|
PRIVATE
|
|
- ${OPENSSL_LIBRARIES}
|
|
- ${LIBSSH2_LIBRARY}
|
|
- ${LIBCRYPTO_LIBRARY}
|
|
- ${ZLIB_LIBRARY}
|
|
+ Libssh2::libssh2
|
|
+ OpenSSL::SSL OpenSSL::Crypto
|
|
+ ZLIB::ZLIB
|
|
)
|
|
|
|
if("${CMAKE_SYSTEM_NAME}" MATCHES "Windows")
|