24 lines
731 B
Diff
Executable File
24 lines
731 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 874a237..3974956 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1617,8 +1617,17 @@ if(CURL_ENABLE_EXPORT_TARGET)
|
|
)
|
|
endif()
|
|
|
|
+set(components_file "${CMAKE_CURRENT_BINARY_DIR}/CURLConfigComponents.cmake")
|
|
+file(CONFIGURE OUTPUT "${components_file}" CONTENT [[
|
|
+foreach(z_vcpkg_curl_component IN ITEMS @SUPPORT_FEATURES@ @SUPPORT_PROTOCOLS@)
|
|
+ if(z_vcpkg_curl_component MATCHES "^[-_a-zA-Z0-9]*$")
|
|
+ set(CURL_${z_vcpkg_curl_component}_FOUND TRUE)
|
|
+ endif()
|
|
+endforeach()
|
|
+]] @ONLY)
|
|
+
|
|
install(
|
|
- FILES ${version_config} ${project_config}
|
|
+ FILES ${version_config} ${project_config} ${components_file}
|
|
DESTINATION ${CURL_INSTALL_CMAKE_DIR}
|
|
)
|
|
|