20 lines
771 B
Diff
Executable File
20 lines
771 B
Diff
Executable File
Workaround for https://github.com/alembic/alembic/issues/309
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -125,14 +125,6 @@ IF (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
|
|
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden")
|
|
ENDIF()
|
|
|
|
-# Set some debug vs opt flags
|
|
-if ("${CMAKE_BUILD_TYPE}" MATCHES "Debug" AND NOT MSVC)
|
|
- add_definitions(-Wall -Werror -Wextra -Wno-unused-parameter -Wno-deprecated)
|
|
- if((CMAKE_CXX_COMPILER_ID MATCHES "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 7.0) OR
|
|
- CMAKE_CXX_COMPILER_ID MATCHES "CLANG")
|
|
- add_definitions( -Wno-error=implicit-fallthrough)
|
|
- endif()
|
|
-endif()
|
|
|
|
IF (NOT ${WINDOWS})
|
|
SET(EXTERNAL_MATH_LIBS "-lm")
|