27 lines
1.1 KiB
Diff
Executable File
27 lines
1.1 KiB
Diff
Executable File
diff --git a/Foundation/CMakeLists.txt b/Foundation/CMakeLists.txt
|
|
index 6b276be..6f5100f 100644
|
|
--- a/Foundation/CMakeLists.txt
|
|
+++ b/Foundation/CMakeLists.txt
|
|
@@ -103,6 +103,21 @@ set_target_properties(Foundation
|
|
if(POCO_UNBUNDLED)
|
|
target_link_libraries(Foundation PUBLIC Pcre::Pcre ZLIB::ZLIB)
|
|
target_compile_definitions(Foundation PUBLIC POCO_UNBUNDLED)
|
|
+ add_definitions(
|
|
+ -D_pcre_utf8_table1=_poco_pcre_utf8_table1
|
|
+ -D_pcre_utf8_table1_size=_poco_pcre_utf8_table1_size
|
|
+ -D_pcre_utf8_table2=_poco_pcre_utf8_table2
|
|
+ -D_pcre_utf8_table3=_poco_pcre_utf8_table3
|
|
+ -D_pcre_utf8_table4=_poco_pcre_utf8_table4
|
|
+ -D_pcre_utt_names=_poco_pcre_utt_names
|
|
+ -D_pcre_utt=_poco_pcre_utt
|
|
+ -D_pcre_utt_size=_poco_pcre_utt_size
|
|
+ -D_pcre_OP_lengths=_poco_pcre_OP_lengths
|
|
+ -D_pcre_hspace_list=_poco_pcre_hspace_list
|
|
+ -D_pcre_vspace_list=_poco_pcre_vspace_list
|
|
+ -D_pcre_ucp_gentype=_poco_pcre_ucp_gentype
|
|
+ -D_pcre_ucp_gbtable=_poco_pcre_ucp_gbtable
|
|
+ )
|
|
endif(POCO_UNBUNDLED)
|
|
|
|
target_include_directories(Foundation
|