12 lines
375 B
Diff
Executable File
12 lines
375 B
Diff
Executable File
--- a/modules/highgui/CMakeLists.txt
|
|
+++ b/modules/highgui/CMakeLists.txt
|
|
@@ -271,7 +271,7 @@ if(APPLE)
|
|
add_apple_compiler_options(${the_module})
|
|
endif()
|
|
|
|
-if(OPENCV_HIGHGUI_BUILTIN_BACKEND STREQUAL "WIN32UI" AND HAVE_OPENGL AND OPENGL_LIBRARIES)
|
|
+if(HAVE_OPENGL AND OPENGL_LIBRARIES)
|
|
ocv_target_link_libraries(${the_module} PRIVATE "${OPENGL_LIBRARIES}")
|
|
endif()
|
|
|