153 lines
5.6 KiB
Diff
Executable File
153 lines
5.6 KiB
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 8dfbc5e..0ba8887 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -373,13 +373,9 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
|
|
|
|
if(OPENVDB_INSTALL_CMAKE_MODULES)
|
|
set(OPENVDB_CMAKE_MODULES
|
|
- cmake/FindBlosc.cmake
|
|
cmake/FindJemalloc.cmake
|
|
- cmake/FindIlmBase.cmake
|
|
cmake/FindLog4cplus.cmake
|
|
- cmake/FindOpenEXR.cmake
|
|
cmake/FindOpenVDB.cmake
|
|
- cmake/FindTBB.cmake
|
|
cmake/OpenVDBGLFW3Setup.cmake
|
|
cmake/OpenVDBHoudiniSetup.cmake
|
|
cmake/OpenVDBMayaSetup.cmake
|
|
diff --git a/cmake/FindOpenVDB.cmake b/cmake/FindOpenVDB.cmake
|
|
index 0dac1de..5014c6a 100644
|
|
--- a/cmake/FindOpenVDB.cmake
|
|
+++ b/cmake/FindOpenVDB.cmake
|
|
@@ -485,7 +485,7 @@ endif()
|
|
|
|
# Add standard dependencies
|
|
|
|
-find_package(TBB REQUIRED COMPONENTS tbb)
|
|
+find_package(TBB CONFIG REQUIRED)
|
|
|
|
if(NOT OPENVDB_USE_STATIC_LIBS AND NOT Boost_USE_STATIC_LIBS)
|
|
# @note Both of these must be set for Boost 1.70 (VFX2020) to link against
|
|
@@ -635,7 +635,7 @@ elseif(NOT OPENVDB_USE_STATIC_LIBS)
|
|
endif()
|
|
|
|
if(OpenVDB_USES_BLOSC)
|
|
- find_package(Blosc REQUIRED)
|
|
+ find_package(blosc CONFIG REQUIRED)
|
|
endif()
|
|
|
|
if(OpenVDB_USES_ZLIB)
|
|
@@ -649,7 +649,7 @@ endif()
|
|
if(OpenVDB_USES_IMATH_HALF)
|
|
find_package(Imath CONFIG)
|
|
if (NOT TARGET Imath::Imath)
|
|
- find_package(IlmBase REQUIRED COMPONENTS Half)
|
|
+ find_package(IlmBase CONFIG REQUIRED)
|
|
endif()
|
|
|
|
if(WIN32)
|
|
@@ -698,7 +698,7 @@ set(_OPENVDB_HIDDEN_DEPENDENCIES)
|
|
|
|
if(NOT OPENVDB_USE_STATIC_LIBS)
|
|
if(OpenVDB_USES_BLOSC)
|
|
- list(APPEND _OPENVDB_HIDDEN_DEPENDENCIES Blosc::blosc)
|
|
+ list(APPEND _OPENVDB_HIDDEN_DEPENDENCIES blosc)
|
|
endif()
|
|
if(OpenVDB_USES_ZLIB)
|
|
list(APPEND _OPENVDB_HIDDEN_DEPENDENCIES ZLIB::ZLIB)
|
|
diff --git a/openvdb/openvdb/CMakeLists.txt b/openvdb/openvdb/CMakeLists.txt
|
|
index 1d5b75f..f2da6f9 100644
|
|
--- a/openvdb/openvdb/CMakeLists.txt
|
|
+++ b/openvdb/openvdb/CMakeLists.txt
|
|
@@ -127,9 +127,9 @@ if(OPENVDB_FUTURE_DEPRECATION AND FUTURE_MINIMUM_BOOST_VERSION)
|
|
endif()
|
|
endif()
|
|
|
|
-find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbb)
|
|
+find_package(TBB CONFIG REQUIRED)
|
|
if(OPENVDB_FUTURE_DEPRECATION AND FUTURE_MINIMUM_TBB_VERSION)
|
|
- if(${Tbb_VERSION} VERSION_LESS FUTURE_MINIMUM_TBB_VERSION)
|
|
+ if(${TBB_VERSION} VERSION_LESS FUTURE_MINIMUM_TBB_VERSION)
|
|
message(DEPRECATION "Support for TBB versions < ${FUTURE_MINIMUM_TBB_VERSION} "
|
|
"is deprecated and will be removed.")
|
|
endif()
|
|
@@ -138,7 +138,7 @@ endif()
|
|
if(USE_IMATH_HALF)
|
|
find_package(Imath CONFIG)
|
|
if (NOT TARGET Imath::Imath)
|
|
- find_package(IlmBase ${MINIMUM_ILMBASE_VERSION} REQUIRED COMPONENTS Half)
|
|
+ find_package(IlmBase CONFIG REQUIRED)
|
|
if(OPENVDB_FUTURE_DEPRECATION AND FUTURE_MINIMUM_ILMBASE_VERSION)
|
|
if(${IlmBase_VERSION} VERSION_LESS FUTURE_MINIMUM_ILMBASE_VERSION)
|
|
message(DEPRECATION "Support for IlmBase versions < ${FUTURE_MINIMUM_ILMBASE_VERSION} "
|
|
@@ -157,26 +157,7 @@ endif()
|
|
|
|
if(USE_BLOSC)
|
|
# Find Blosc libraries
|
|
- find_package(Blosc ${MINIMUM_BLOSC_VERSION} REQUIRED)
|
|
- if(Blosc_VERSION)
|
|
- if(OPENVDB_FUTURE_DEPRECATION AND FUTURE_MINIMUM_BLOSC_VERSION)
|
|
- if(${Blosc_VERSION} VERSION_LESS FUTURE_MINIMUM_BLOSC_VERSION)
|
|
- message(DEPRECATION "Support for Blosc versions < ${FUTURE_MINIMUM_BLOSC_VERSION} "
|
|
- "is deprecated and will be removed.")
|
|
- endif()
|
|
- endif()
|
|
- # Print a warning if using of the blosc versions with regression issues
|
|
- # with Blosc 1.5.0 caches.
|
|
- if((Blosc_VERSION VERSION_GREATER_EQUAL 1.11.0 AND
|
|
- Blosc_VERSION VERSION_LESS 1.14.0) OR
|
|
- (Blosc_VERSION VERSION_GREATER_EQUAL 1.16.0 AND
|
|
- Blosc_VERSION VERSION_LESS 1.16.2))
|
|
- message(WARNING "The following Blosc versions are incompatible with the "
|
|
- "recommended builds of OpenVDB: [1.11.0 -> 1.14.0) [1.16.0, 1.16.1]. "
|
|
- "Found Blosc version '${Blosc_VERSION}' which falls in this range. We "
|
|
- "strongly recommend using the new future minimum version '${FUTURE_MINIMUM_BLOSC_VERSION}'")
|
|
- endif()
|
|
- endif()
|
|
+ find_package(blosc CONFIG REQUIRED)
|
|
else()
|
|
message(WARNING "Blosc support is disabled. It is strongly recommended to "
|
|
"enable blosc for optimal builds of OpenVDB and to support compatible "
|
|
@@ -234,7 +215,7 @@ endif()
|
|
# /usr/local
|
|
|
|
if(USE_BLOSC)
|
|
- list(APPEND OPENVDB_CORE_DEPENDENT_LIBS Blosc::blosc)
|
|
+ list(APPEND OPENVDB_CORE_DEPENDENT_LIBS blosc)
|
|
endif()
|
|
|
|
if(USE_BLOSC OR USE_ZLIB)
|
|
diff --git a/openvdb/openvdb/cmd/CMakeLists.txt b/openvdb/openvdb/cmd/CMakeLists.txt
|
|
index c1d5649..c173566 100644
|
|
--- a/openvdb/openvdb/cmd/CMakeLists.txt
|
|
+++ b/openvdb/openvdb/cmd/CMakeLists.txt
|
|
@@ -46,7 +46,7 @@ if(CONCURRENT_MALLOC STREQUAL "Jemalloc")
|
|
find_package(Jemalloc REQUIRED)
|
|
list(APPEND OPENVDB_BINARIES_DEPENDENT_LIBS Jemalloc::jemalloc)
|
|
elseif(CONCURRENT_MALLOC STREQUAL "Tbbmalloc")
|
|
- find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbbmalloc)
|
|
+ find_package(TBB CONFIG REQUIRED)
|
|
list(APPEND OPENVDB_BINARIES_DEPENDENT_LIBS TBB::tbbmalloc)
|
|
endif()
|
|
|
|
@@ -90,17 +90,13 @@ if(OPENVDB_BUILD_VDB_RENDER)
|
|
find_package(Imath CONFIG)
|
|
if (NOT TARGET Imath::Imath)
|
|
if(USE_EXR)
|
|
- find_package(IlmBase ${MINIMUM_ILMBASE_VERSION} REQUIRED COMPONENTS Half Iex IlmThread Imath)
|
|
- else()
|
|
- find_package(IlmBase ${MINIMUM_ILMBASE_VERSION} REQUIRED COMPONENTS Half)
|
|
+ find_package(IlmBase CONFIG REQUIRED)
|
|
endif()
|
|
endif()
|
|
endif()
|
|
|
|
if(USE_EXR)
|
|
if (NOT TARGET Imath::Imath)
|
|
- find_package(OpenEXR ${MINIMUM_OPENEXR_VERSION} REQUIRED COMPONENTS IlmImf)
|
|
- else()
|
|
find_package(OpenEXR CONFIG REQUIRED)
|
|
endif()
|
|
endif()
|