13 lines
375 B
Diff
Executable File
13 lines
375 B
Diff
Executable File
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index bec81d4..44fd48a 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1,6 +1,6 @@
|
|
cmake_minimum_required(VERSION 3.1)
|
|
|
|
-if (WIN32)
|
|
+if (WIN32 AND BUILD_SHARED_LIBS)
|
|
set(Boost_USE_STATIC_LIBS OFF)
|
|
# The auto-linking feature has problems with USE_STATIC_LIBS off, so we use
|
|
# BOOST_ALL_NO_LIB to turn it off.
|